Ha habido un error al subir el fichero en WordPress: Sólo se ha podido subir una parte del mismo


Tras actualizar el sistema operativo Debian GNU/Linux era imposible subir ficheros de medios (vídeos e imágenes) al WordPress. El error arrojado no era descriptivo:

Sólo se ha podido subir una parte del archivo.

Error arrojado al intentar subir una serie de imágenes para adjuntarlas a una nueva entrada en WordPress.
Error arrojado al intentar subir una serie de imágenes para adjuntarlas a una nueva entrada en WordPress.

Tras analizar los permisos de los directorios del WordPress (usuario www-data), los logs activando el modo debug, la configuración del servidor Apache… ¡todo estaba bien! Tras darle vueltas e indagar en el asunto buscando una solución al problema, ningún buscador arrojaba respuestas concluyentes al problema. Sin embargo, en stackexchange encontré un usuario que mencionaba que el paquete libapache2-mod-php5filter era el causante de esto y que así solventó el problema. Me decidí a probar:

usuario@debian:/etc/apache2$ sudo apt-get remove libapache2-mod-php5filter
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Se instalarán los siguientes paquetes extras:
  libapache2-mod-php5
Paquetes sugeridos:
  php-pear
Los siguientes paquetes se ELIMINARÁN:
  libapache2-mod-php5filter
Se instalarán los siguientes paquetes NUEVOS:
  libapache2-mod-php5
0 actualizados, 1 nuevos se instalarán, 1 para eliminar y 2 no actualizados.
Se necesita descargar 2.227 kB de archivos.
Se utilizarán 1.024 B de espacio de disco adicional después de esta operación.
¿Desea continuar? [S/n] S
Des:1 http://security.debian.org/ jessie/updates/main libapache2-mod-php5 amd64 5.6.29+dfsg-0+deb8u1 [2.227 kB]
Descargados 2.227 kB en 0s (4.741 kB/s)
dpkg: libapache2-mod-php5filter: problemas de dependencias, pero se desinstalará de todas formas
 tal y como se solicitó:
 php5 depende de libapache2-mod-php5 (>= 5.6.29+dfsg-0+deb8u1~) | libapache2-mod-php5filter (>= 5.6.29+dfsg-0+deb8u1~) | php5-cgi (>= 5.6.29+dfsg-0+deb8u1~) | php5-fpm (>= 5.6.29+dfsg-0+deb8u1~); sin embargo:
  El paquete `libapache2-mod-php5' no está instalado.
  El paquete `libapache2-mod-php5filter' va a ser desinstalado.
  El paquete `php5-cgi' no está instalado.
  El paquete `php5-fpm' no está instalado.

(Leyendo la base de datos ... 20794 ficheros o directorios instalados actualmente.)
Desinstalando libapache2-mod-php5filter (5.6.29+dfsg-0+deb8u1) ...
php5_invoke prerm: Disable module opcache for apache2filter SAPI
php5_invoke prerm: Disable module gd for apache2filter SAPI
php5_invoke prerm: Disable module pdo_mysql for apache2filter SAPI
php5_invoke prerm: Disable module json for apache2filter SAPI
php5_invoke prerm: Disable module mysql for apache2filter SAPI
php5_invoke prerm: Disable module mysqli for apache2filter SAPI
php5_invoke prerm: Disable module pdo for apache2filter SAPI
Module php5filter disabled.
apache2_invoke prerm: Disable module php5filter
[ ok ] Restarting web server: apache2.
Seleccionando el paquete libapache2-mod-php5 previamente no seleccionado.
(Leyendo la base de datos ... 20786 ficheros o directorios instalados actualmente.)
Preparando para desempaquetar .../libapache2-mod-php5_5.6.29+dfsg-0+deb8u1_amd64.deb ...
Desempaquetando libapache2-mod-php5 (5.6.29+dfsg-0+deb8u1) ...
Configurando libapache2-mod-php5 (5.6.29+dfsg-0+deb8u1) ...
php5_invoke: Enable module opcache for apache2 SAPI
php5_invoke: Enable module gd for apache2 SAPI
php5_invoke: Enable module pdo_mysql for apache2 SAPI
php5_invoke: Enable module json for apache2 SAPI
php5_invoke: Enable module mysql for apache2 SAPI
php5_invoke: Enable module mysqli for apache2 SAPI
php5_invoke: Enable module pdo for apache2 SAPI
apache2_invoke: Enable module php5
[ ok ] Restarting web server: apache2.

Tras verificar que todos los servicios se encuentran disponibles, al final se volvió a probar la subida de ficheros, la cual fue finalmente exitosa.

Ficheros subidos con éxito a la galería de medios de WordPress.
Ficheros subidos con éxito a la galería de medios de WordPress.

Finalmente, indicar que desconozco cómo se instaló el paquete pero intuyo que con la última actualización del SO (de Debian 7 a Debian 8). En los detalles del paquete de Debian ya se indica claramente que en vez de utilizar libapache2-mod-php5filter debe utilizarse libapache2-mod-php5, por lo que si no se dispone de este último paquete instalado habrá que hacerlo tras eliminar el primero.